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Introduction  

Military Icon is a single WPF control that can be used to configure 1,200+ military war fighting symbols 

based on the MIL-STD-2525B specification. This control is intended for use by developers creating .NET 

3.5 WPF applications targeted for the Windows platform. 
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Dependency Properties  

Military Icon is controlled by a short list of dependency properties. They are as follows: 

 

HostilityLevel 

 The hostility level of the represented unit. Type is MI2525B.HostilityLevel. 

BattleDimension 

The battle dimension of the represented unit. This property is used in determining the shape of the 

background image. Type is MI2525B.BattleDimension. 

Position 

The position of the represented unit relative to its parent canvas. Used to calculate the direction. Type is 

System.Windows.Point. 

ShowDirection 

Toggles whether the direction indicator of the icon is displayed. Type is Boolean. 

UnitType 

The unit type of the represented unit. Type is MI2525B.UnitType. 
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Enumerable Values  

Each enum has multiple values that allow you to customize the Icon in various ways: 

BattleDimension: 

¶ AboveSurface 

¶ SurfaceUnit 

¶ SurfaceEquipment 

¶ SurfaceInstallation 

¶ BelowSurface 

HostilityLevel: 

¶ Friendly 

¶ Hostile 

¶ Neutral 

¶ Unknown 

UnitType: 

¶ WAR_AIRTRK_MIL 

¶ WAR_AIRTRK_MIL_FIXD 

¶ WAR_AIRTRK_MIL_FIXD_MEDV 

¶ WAR_AIRTRK_MIL_LTA 

¶ WAR_GRDTRK_EQT_WPN_ATRL 

¶ WAR_GRDTRK_EQT_WPN_GREL 

¶ WAR_GRDTRK_EQT_WPN_HOW 

¶ WAR_GRDTRK_EQT_WPN_MORT 

¶ WAR_GRDTRK_EQT_WPN_MRL 

¶ WAR_GRDTRK_EQT_WPN_MSLL 

¶ WAR_GRDTRK_EQT_WPN_MSLL_ADFAD 

¶ WAR_GRDTRK_EQT_WPN_MSLL_ADFAD_INTMR 

¶ WAR_GRDTRK_EQT_WPN_MSLL_ADFAD_LNGR 

¶ WAR_GRDTRK_EQT_WPN_MSLL_AT 

¶ WAR_GRDTRK_EQT_WPN_MSLL_SUF 

¶ WAR_GRDTRK_EQT_WPN_RIFWPN 

¶ WAR_GRDTRK_EQT_WPN_SRL 

¶ WAR_GRDTRK_UNT_CBT 

¶ WAR_GRDTRK_UNT_CBT_AARM 

¶ WAR_GRDTRK_UNT_CBT_ADF 

¶ WAR_GRDTRK_UNT_CBT_ADF_CMPS 

¶ WAR_GRDTRK_UNT_CBT_ADF_GUNUNT 

¶ WAR_GRDTRK_UNT_CBT_ADF_MSL 

¶ WAR_GRDTRK_UNT_CBT_ADF_SHTR 

¶ WAR_GRDTRK_UNT_CBT_ADF_SHTR_CPL 

¶ WAR_GRDTRK_UNT_CBT_ADF_SHTR_STG 

¶ WAR_GRDTRK_UNT_CBT_ADF_SHTR_VUL 

¶ WAR_GRDTRK_UNT_CBT_ADF_TGTGUT 

¶ WAR_GRDTRK_UNT_CBT_ADF_TMDU 

¶ WAR_GRDTRK_UNT_CBT_ARM 

¶ WAR_GRDTRK_UNT_CBT_ARM_TRK 

¶ WAR_GRDTRK_UNT_CBT_ARM_WHD 

¶ WAR_GRDTRK_UNT_CBT_AVN 

¶ WAR_GRDTRK_UNT_CBT_AVN_CMPS 

¶ WAR_GRDTRK_UNT_CBT_AVN_FIXD 

¶ WAR_GRDTRK_UNT_CBT_AVN_ROT 

¶ WAR_GRDTRK_UNT_CBT_AVN_SAR 

¶ WAR_GRDTRK_UNT_CBT_AVN_UAV 

¶ WAR_GRDTRK_UNT_CBT_ENG 

¶ WAR_GRDTRK_UNT_CBT_ENG_CSN 

¶ WAR_GRDTRK_UNT_CBT_FLDART 

¶ WAR_GRDTRK_UNT_CBT_FLDART_ARTSVY 

¶ WAR_GRDTRK_UNT_CBT_FLDART_HOW 

¶ WAR_GRDTRK_UNT_CBT_FLDART_METO 

¶ WAR_GRDTRK_UNT_CBT_FLDART_MORT 

¶ WAR_GRDTRK_UNT_CBT_FLDART_ROC 

¶ WAR_GRDTRK_UNT_CBT_FLDART_ROC_MRL 

¶ WAR_GRDTRK_UNT_CBT_FLDART_ROC_SRL 

¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ 

¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ_ANG 

¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ_CLT 

¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ_FLH 
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¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ_RAD 

¶ WAR_GRDTRK_UNT_CBT_FLDART_TGTAQ_SND 

¶ WAR_GRDTRK_UNT_CBT_INF 

¶ WAR_GRDTRK_UNT_CBT_INF_AAST 

¶ WAR_GRDTRK_UNT_CBT_INF_ABN 

¶ AR_GRDTRK_UNT_CBT_INF_ARC 

¶ WAR_GRDTRK_UNT_CBT_INF_INFFV 

¶ WAR_GRDTRK_UNT_CBT_INF_LIT 

¶ WAR_GRDTRK_UNT_CBT_INF_MECH 

¶ WAR_GRDTRK_UNT_CBT_INF_MNT 

¶ WAR_GRDTRK_UNT_CBT_INF_MOT 

¶ WAR_GRDTRK_UNT_CBT_INF_NAV 

¶ WAR_GRDTRK_UNT_CBT_ISF 

¶ WAR_GRDTRK_UNT_CBT_ISF_AVN 

¶ WAR_GRDTRK_UNT_CBT_ISF_GRD_ 

¶ WAR_GRDTRK_UNT_CBT_ISF_GRD_DMD 

¶ WAR_GRDTRK_UNT_CBT_ISF_GRD_MECH 

¶ WAR_GRDTRK_UNT_CBT_ISF_GRD_MOT 

¶ WAR_GRDTRK_UNT_CBT_ISF_RALRD 

¶ WAR_GRDTRK_UNT_CBT_ISF_RIV 

¶ WAR_GRDTRK_UNT_CBT_ISF_WHMECH 

¶ WAR_GRDTRK_UNT_CBT_MSL 

¶ WAR_GRDTRK_UNT_CBT_MSL_STGC 

¶ WAR_GRDTRK_UNT_CBT_MSL_TAC 

¶ WAR_GRDTRK_UNT_CBT_RECON 

¶ WAR_GRDTRK_UNT_CBT_RECON_CVY 

¶ WAR_GRDTRK_UNT_CBT_RECON_HRE 

¶ WAR_GRDTRK_UNT_CS 

¶ WAR_GRDTRK_UNT_CS_EOD 

¶ WAR_GRDTRK_UNT_CS_IWU 

¶ WAR_GRDTRK_UNT_CS_LAWENU 

¶ WAR_GRDTRK_UNT_CS_LAWENU_CID 

¶ WAR_GRDTRK_UNT_CS_LAWENU_CLE 

¶ WAR_GRDTRK_UNT_CS_LAWENU_MILP 

¶ WAR_GRDTRK_UNT_CS_LAWENU_SECPOL 

¶ WAR_GRDTRK_UNT_CS_LAWENU_SHRPAT 

¶ WAR_GRDTRK_UNT_CS_LNDSUP 

¶ WAR_GRDTRK_UNT_CS_MILINT 

¶ WAR_GRDTRK_UNT_CS_MILINT_AEREXP 

¶ WAR_GRDTRK_UNT_CS_MILINT_CINT 

¶ WAR_GRDTRK_UNT_CS_MILINT_INTGN 

¶ WAR_GRDTRK_UNT_CS_MILINT_JINTCT 

¶ WAR_GRDTRK_UNT_CS_MILINT_OPN 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_ARM

WVH 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_CRP 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_DFN 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_INC 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_JMG 

¶ WAR_GRDTRK_UNT_CS_MILINT_SIGINT_ECW_THT 

¶ WAR_GRDTRK_UNT_CS_MILINT_SVL 

¶ WAR_GRDTRK_UNT_CS_MILINT_TACEXP 

¶ WAR_GRDTRK_UNT_CS_NBC 

¶ WAR_GRDTRK_UNT_CS_NBC_BIO 

¶ WAR_GRDTRK_UNT_CS_NBC_CML_RECON 

¶ WAR_GRDTRK_UNT_CS_NBC_CML_SMK 

¶ WAR_GRDTRK_UNT_CS_NBC_DECON 

¶ WAR_GRDTRK_UNT_CS_NBC_NUC 

¶ WAR_GRDTRK_UNT_CS_SIGUNT 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_ARA 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_CMDOPN 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_COMCP 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_ECRG 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_FWDCOM 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_PHOSWT 

¶ WAR_GRDTRK_UNT_CS_SIGUNT_SIGSU 

¶ WAR_GRDTRK_UNT_CSS 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_FIN 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_JAG 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_LBR 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_MTRY 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_MWR 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_PERSVC 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_PST 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_PUBAFF 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_RELG 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_RHU 

¶ WAR_GRDTRK_UNT_CSS_ADMIN_SUPPLY 

¶ WAR_GRDTRK_UNT_CSS_MAINT 

¶ WAR_GRDTRK_UNT_CSS_MAINT_EOP 

¶ WAR_GRDTRK_UNT_CSS_MAINT_ORD 

¶ WAR_GRDTRK_UNT_CSS_MED 

¶ WAR_GRDTRK_UNT_CSS_MED_DEN 

¶ WAR_GRDTRK_UNT_CSS_MED_MEDTF 

¶ WAR_GRDTRK_UNT_CSS_MED_PSY 

¶ WAR_GRDTRK_UNT_CSS_MED_VNY 

¶ WAR_GRDTRK_UNT_CSS_SLP 

¶ WAR_GRDTRK_UNT_CSS_TPT 

¶ WAR_GRDTRK_UNT_CSS_TPT_APOD 

¶ WAR_GRDTRK_UNT_CSS_TPT_MCC 

¶ WAR_GRDTRK_UNT_CSS_TPT_MSL 

¶ WAR_GRDTRK_UNT_CSS_TPT_RHD 

¶ WAR_GRDTRK_UNT_CSS_TPT_SPOD 

¶ WAR_SPC_CSV 

¶ WAR_SPC_SAT 

¶ WAR_SPC_SST 
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Usage 

You can use the Icon in various ways: 

C# Usage: 

é 

Using MI2525B;  

é 

Icon2525B icon = new Icon2525B();  

icon.HostilityLevel = HostilityLevel.Friendly;  

icon.BattleDimension = BattleDimension.SurfaceUnit;  

icon.UnitType = UnitType.WAR_CRDTRK_UNT_CBT_RECON;  

 

//Set the initial Position  

icon.Position = new Point(87, 256);  

myCanvas.Children.Add(icon);  

 

XAML Usage: 

<Canvas>  

<MI2525B:Icon2525B  

 HostilityLevel=òFriendlyò 

 Position=ò87, 256ò 

 ShowDirection=òTrueò 

 BattleDimension=òSurfaceUnitò 

 UnitType=òWAR_GRDTRK_UNT_CBT_RECONò /> 

</Canvas>  
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Using Military Icon with Aurora for Architects  

1. Launch Aurora for Architects. You can generally find the shortcut for it on your desktop, in the 

Start Menu, or you can navigate to your Program Files directory and open it from there. 

 

2. Once Aurora for Architects has finished loading, you can select a new XAML document by 

clicking the New File toolbar icon, or by clicking File->New->Drawing. Select your document type 

(use Empty Canvas for this demonstration) and click OK.  

 
3. Click on the Toolbox tab and select, then single-ŎƭƛŎƪ ǘƘŜ άоǊŘ tŀǊǘȅέ ŜȄǇŀƴŘŜǊ then ά!ŘŘ ²tC 

/ƻƴǘǊƻƭέΦ ¢Ƙƛǎ ǿƛƭƭ ƭŀǳƴŎƘ ŀ ōǊƻǿǎŜ ŘƛŀƭƻƎ ǎƻ ǘƘŀǘ ȅƻǳ Ŏŀƴ ƴŀǾƛƎŀǘŜ ǘƻ ǘƘŜ Military Icon DLL 

(usually in C:\Program Files\Mobiform Software\Military Icon\bin\). Once you have located the 

DLL, select it by single-clicking on it and click OK. A new prompt will appear that will list all of the 

controls in the DLL. Select the Icon control from the list. 

 

  



Copyright © 2008 Mobiform Software, Inc. 9 
 

4. Now that you have added in your 3rd party control, you can select it from the Toolbox panel and 

start using it in your XAML document. You can draw the control by dragging it directly from the 

Toolbox onto the design surface, or single-click the control then click in the window and drag 

toward the bottom right corner of the window. 

 
5. Change some of the dependency properties and click test run to see how the control will react 

at runtime. 

Congratulations! You are now ready to start using the Military Icon with Aurora for Architects! 
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Using Military Icon with Visual Studio 2008  

1. Launch Visual Studio 2008. You can generally find the shortcut for it on your desktop, in the 

Start Menu, or you can navigate to your Program Files directory and open it from there. 

 

2. Once Visual Studio has finished loading, click File->New->Project. From the New Project dialog, 

select a project type (use WPF Application for this demonstration), and click OK. 
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3. When the project has finished loading, locate your Toolbox panel, then right click and select 

ά!ŘŘ ¢ŀōέΦ CƻǊ ǘƘŜ ǇǳǊǇƻǎŜ ƻŦ ǘƘƛǎ ŘŜƳƻƴǎǘǊŀǘƛƻƴΣ ȅƻǳ ǿƛƭƭ ƴŀƳŜ ǘƘƛǎ ǘŀō άMilitary IconέΦ ¢ƻ 

name the tab, simply type the name in the field and press enter. 
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4. After naming the tab, right click ƛƴ ǘƘŜ ǘŀō ŀƴŘ ǎŜƭŜŎǘ ά/ƘƻƻǎŜ LǘŜƳǎέ ǘƻ ōǊƛƴƎ ǳǇ ǘƘŜ /ƘƻƻǎŜ 

¢ƻƻƭōƻȄ LǘŜƳǎ ŘƛŀƭƻƎΦ /ƭƛŎƪ ƻƴ ǘƘŜ ά²tC /ƻƳǇƻƴŜƴǘǎέ ǘŀōΣ ŀƴŘ ǘƘŜƴ ǇǊŜǎǎ ǘƘŜ άōǊƻǿǎŜέ ōǳǘǘƻƴ 

to bring up the Open dialog. Navigate to where the Military Icon DLL is installed to (generally 

C:\Program Files\Mobiform Software\Military Icon\bin) and select the DLL by single-clicking on 

it then press Open. Notice how upon loading the Icon DLL, the dialog has automatically selected 

the control out of the list. Click OK and you should see the Icon control in your toolbox now. 
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5. Now that you have access to the control in your project, you can start to use it in your window. 

Double-click Window1.xaml in your Solution Explorer to open it up and edit it. Select the control 

from your toolbox and then either drag it from the toolbox to the window or click and drag 

toward the bottom right corner of the window to draw it out. 

 
6. After drawing the control out, you can now start to change the look and feel of it by adjusting 

the various dependency properties, and finally, you can view your compiled application by 

clicking the Debug on the toolbar. 

Congratulations! You are now ready to start using the Military Icon with Visual Studio 2008! 
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Using Military Icon with Expression Blend  

1. Open Expression Blend. You can generally find the shortcut for it on your desktop, in the Start 

Menu, or you can navigate to your Program Files and open it from there. 

 

2. Once Expression Blend has finished loading, click File->New Project to bring the New Project 

dialog up. Select a project type (WPF Application using .NET 3.5 for this demonstration) and click 

OK. 

 
3. When the project has loaded, Right-ŎƭƛŎƪ ƻƴ ǘƘŜ wŜŦŜǊŜƴŎŜǎ ŦƻƭŘŜǊ ŀƴŘ ǎŜƭŜŎǘ ά!ŘŘ wŜŦŜǊŜƴŎŜέΦ 

In the Browse dialog, navigate to where the Military Icon DLL is installed to (generally this is 

located in C:\Program Files\Mobiform Software\Military Icon\bin\) then select the DLL by single-

clicking on it and click OK. 
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4. Now that the reference to the Military Icon DLL has been added, you can now access the control 

from the Asset Library tab, which is on the Toolbar at the very bottom. Click on the Asset Library 

button to open the control Library and click on the Custom Controls tab to view the controls 

that are located inside the DLL. Select the control and then either drag the control from the 

library into the window or click the control then click and drag toward the bottom right corner 

of the window to it out. 

 
5. After drawing the control out, you can start to change the look and feel of it by adjusting the 

various dependency properties in the properties tab, and finally, you can view your compiled 

application by clicking Project->Test Solution on the File Menu bar. 

 

Congratulations! You are now ready to start using the Military Icon with Expression Blend! 
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